POSFriends

This is the only category? => The Posting Range => Topic started by: Soaprman on June 02, 2015, 08:29:56 AM

Title: Bug Reports/Change Requests
Post by: Soaprman on June 02, 2015, 08:29:56 AM
If you experience problems with the forum or site, post them here. Bugs reported elsewhere (in other threads, in Skype chat, etc.) may be ignored. Change requests are also fine to post.

Things to post about:

If you are experiencing a problem with the forum, and it's not super obvious that it's happening, please include the following information or your post will be ignored:

Also, only post one bug report or change request per post, please. It makes things easier for me to keep up with.
Title: Re: Bug Reports
Post by: Malik on June 02, 2015, 01:38:03 PM
A screenshot of the error happening
Firefox
Desktop
Depths of Hyrule
No Fullscreen Posting
Should be obvious but http://thedailypos.org/friends/index.php/topic,354.msg5675.html#new

(http://i.imgur.com/AqvlSGs.png)
IDK these were fine last time I checked but when I updated I noticed the :dk: :swoon: :link: emoticons weren't displaying,  :cranky: still does though? I did a test reply and the same thing happened with :link:
Maybe it has something to do with the audio tags?

(http://i.imgur.com/4KAjKgk.png)
Not really a bug but I thought anything that ain't working like it should should be known. For some reason when I scroll up and down the text gets really messed up the more I do it. I've only seen this work with the Hidden spoiler text. It can get so bad that the letters become unrecognizable.


Title: Re: Bug Reports
Post by: KarmaPolice on June 02, 2015, 02:44:08 PM
There was a big spider in the junk heap
Title: Re: Bug Reports
Post by: Space Raton on June 02, 2015, 03:02:36 PM
Those are very thorough guidelines for bug reporting... it's almost like you do this sort of thing for a living!
Title: Re: Bug Reports
Post by: Soaprman on June 02, 2015, 03:27:11 PM
emoticons weren't displaying

Fixed. The cause was an extra line break in the bbcode definition causing the parser to throw an exception as it parsed the post. This is why emoticons before the audio tag worked while emoticons after it didn't.
Title: Re: Bug Reports
Post by: Soaprman on June 02, 2015, 03:28:41 PM
There was a big spider in the junk heap

Working as designed.
Title: Re: Bug Reports
Post by: Scrow Funk on June 02, 2015, 03:39:27 PM
Avatars/usernames disappeared from mobile view

(http://puu.sh/i9ZhR/fd0508ecf5.png)

chrome
android
default
full screen
Title: Re: Bug Reports
Post by: Soaprman on June 02, 2015, 03:44:48 PM
Which version? Works fine for me on 43.0.2357.78
Title: Re: Bug Reports
Post by: Soaprman on June 02, 2015, 03:46:06 PM
mama mia that's a big screenie
Title: Re: Bug Reports
Post by: Scrow Funk on June 02, 2015, 03:54:21 PM
version 35.0.1.1916.141
Title: Re: Bug Reports
Post by: Space Raton on June 02, 2015, 04:27:32 PM
mama mia that's a big screenie

Ya got a Note too? great fone o/
Title: Re: Bug Reports
Post by: Soaprman on June 02, 2015, 04:32:19 PM
Alright, fixed that thing Scrow was talking about. It was due to the use of CSS display: unset which isn't supported by all browsers, apparently. I found a workaround.

Also, I have a Galaxy S6, actually. Probably about the same thing though? I don't know a lot about smartphomes!
Title: Re: Bug Reports
Post by: Space Raton on June 02, 2015, 05:30:03 PM
Ohh right, those are 1440p as well.

W...wait a minute! This isn't a bug report at all! o_o;
Title: Re: Bug Reports
Post by: Puppet Pal Soap on June 11, 2015, 09:28:46 PM
why is "save in outbox" not on by default soaprman

idk. paste this response of mine in the bug report thread and i'll fix that this weekend
Title: Re: Bug Reports
Post by: Soaprman on June 13, 2015, 12:11:44 PM
I removed that setting and enabled it by default for everybody.
Title: Re: Bug Reports
Post by: Lolicon Jon on June 13, 2015, 12:25:29 PM
For some reason my sig is cutoff from the bottom.

On the POS (http://puu.sh/inol3/c4b45df366.png)

The Original (http://i.imgur.com/irjn2AG.png?1)

Is it just cause it's too big?
Title: Re: Bug Reports
Post by: Space Raton on June 13, 2015, 12:31:44 PM
It's probably incompatible with a forum as modern as this one. Using sig images taller than 100px became obsolete around 2007.
Title: Re: Bug Reports
Post by: Soaprman on June 13, 2015, 01:00:27 PM
The maximum sig height was 20em, but that was awkward since em is a relative unit, so I've changed it to 200px (which is slightly shorter).

Images are resized to have a height of 200px if they are taller than that. Then, the bottom of the entire sig is cut off if its height exceeds 200px.

If you remove the text, your image should look right.

Basically, it's working as designed.
Title: Re: Bug Reports
Post by: Yoshi348 on June 15, 2015, 12:57:03 AM
heres a bug

weedle

Title: Re: Bug Reports
Post by: Soaprman on June 15, 2015, 04:52:49 PM
heres a bug

weedle



  "bitch"
    /
 :weedle:
Title: Re: Bug Reports
Post by: Scrow Funk on June 19, 2015, 03:23:30 PM
Member-level users should have a Delete Post button so I don't look like an asshole when I click quote instead of edit.
Title: Re: Bug Reports
Post by: Soaprman on June 19, 2015, 05:08:54 PM
Now that Akuma is banned and we don't have to worry about legendary Akumaposts vanishing, sure. Permission granted.

Member-level users should have a Delete Post button so I don't look like an asshole when I click quote instead of edit.

Quoting this in case Scrow pulls some kind of Smart Ass Bull Shit and deletes his post as a response to this :cranky:
Title: Re: Bug Reports/Change Requests
Post by: Soaprman on June 19, 2015, 05:10:54 PM
Thread renamed to Bug Reports/Change Requests since I'm alright with the thread being used for both.
Title: Re: Bug Reports/Change Requests
Post by: Scrow Funk on June 19, 2015, 05:20:04 PM
Quoting this in case Scrow pulls some kind of Smart Ass Bull Shit and deletes his post as a response to this :cranky:
I'm shocked that you would think that I'd snatch up that low-hanging of a fruit. In retaliation to this slight, I've deleted an entirely different post that provided context to another post of yours.
Title: Re: Bug Reports/Change Requests
Post by: Scrow Funk on June 19, 2015, 05:22:18 PM
Also, here's a friendly reminder to port over [avatar] tags from the old forum, in case a need for them should arise.
Title: Re: Bug Reports/Change Requests
Post by: Space Raton on June 29, 2015, 12:25:29 AM
Smallish embedded images (like Tanya there) get upscaled with really gross artifacting on my high-dpi mobile display. Actually my avatar looks like that too. Browser is current Chrome for Android.
Title: Re: Bug Reports/Change Requests
Post by: Space Raton on June 29, 2015, 12:28:44 AM
Like if I zoom in here, hoo boy, I've looked better.
Title: Re: Bug Reports/Change Requests
Post by: Soaprman on June 29, 2015, 05:50:01 PM
Tell me if it looks any better now.
Title: Re: Bug Reports/Change Requests
Post by: Space Raton on June 29, 2015, 05:57:42 PM
It does, yes. There's still some blurring from whatever kind of upscaling is being used, but the artifacts are gone.
Title: Re: Bug Reports/Change Requests
Post by: Soaprman on June 29, 2015, 06:14:43 PM
Alright, cool. That's probably the best I can do with just CSS. I'm kind of surprised I was able to do even that much!
Title: Re: Bug Reports/Change Requests
Post by: Space Raton on August 08, 2015, 09:41:20 AM
Youtubes won't "click to load" when previewing a post (either a new post or an edit).
Title: Re: Bug Reports/Change Requests
Post by: Space Raton on February 03, 2016, 10:41:36 AM
(http://i.imgur.com/XGd8n8c.png)
Hmmmm....

(this was on mobile)
Title: Re: Bug Reports/Change Requests
Post by: Soaprman on February 03, 2016, 05:07:14 PM
Yeah, I've seen that before too (and it was even with your username). Not sure what's up with it! I guess next time I'm in the POS codebase I'll take a look. Maybe something you did created an extra session or something.